Home > Linux, Noob's articles > Ставим актуальный iceweasel 11 (firefox) на debian squeeze

Ставим актуальный iceweasel 11 (firefox) на debian squeeze

Пользуясь Debian Squeeze, мы делаем свою работу безопасней, из-за политики выпуска обновлений. С одной стороны это плюс – к нам постоянно приходят заплатки, которые не дают системе сбоить. Этот плюс является одновременно и минусом: версии программ, заключенные в пакеты в ветке stable останутся теми же, что и в день выпуска системы, как это не печально. Соответственно, iceweacel как и был 3.5.16 – так им и останется. Специально для этого разработчиками Debian был придуман проект backports – репозитарий, содержащий в себе откомпилированные под стабильные библиотеки новые версии программ. Сегодня мы обновим iceweacel 🙂

Итак, для начала установим ключик с репозитария mozilla:

# wget http://mozilla.debian.net/pkg-mozilla-archive-keyring_1.0_all.deb

Установим скачанный нами пакет:

# dpkg -i pkg-mozilla-archive-keyring_1.0_all.deb

Добавим в sources.list парочку строчек:

# echo “deb http://backports.debian.org/debian-backports squeeze-backports main”  >> /etc/apt/sources.list
# echo “deb http://backports.debian.org/debian-backports squeeze-backports main contrib non-free”  >> /etc/apt/sources.list
# echo “deb http://mozilla.debian.net/ squeeze-backports iceweasel-release”  >> /etc/apt/sources.list

Обновим список репозитариев:

# aptitude update

Удалим существующую версию iceweasel:

# aptitude -y purge iceweasel

Устанавливаем новую версию iceweasel:

# aptitude – y install -t squeeze-backports iceweasel iceweasel-l10n-ru

Всё, теперь у Вас установлен актуальный iceweasel, который на помент написания статьи был 11.0 🙂 Удачи!

  1. Роман
    March 22nd, 2012 at 13:45 | #1

    жаль что на idove они забили, последний 5.0

  2. erdees
    March 22nd, 2012 at 18:36 | #2

    @Роман
    Да, печально)
    Кстати я статейку написал на эту тему, может пригодится:
    https://erdees.ru/linux-soft/ustanovka-thunderbird-11-na-debian-squeeze-iz-repozitariev-mepis/

  3. Роман
    March 23rd, 2012 at 12:11 | #3

    подтверждаю, работает

  4. PageUp
    July 4th, 2012 at 00:34 | #4

    Выполнение первой строчки для добавления репозитория бессмысленно.

    Правильно писать “-y”, а не “— y”.
    А лучше вообще не делать так.
    Я вовремя успел нажать отмету. При установке нового айсвизла мне предлагалось удалить половину систему.
    Будьте внимательны. Лучше убрать “-у” из статьи.

    • erdees
      July 4th, 2012 at 09:46 | #5

      Ну, значит траблы с зависимостями в системе, раз чуть не снес половину всех пакетов. И при выполнении каких-либо действий от root, нужно понимать и отдавать себе отчеты о том, что делаешь.

      >> Правильно писать «-y», а не «— y»

      Да написано именно все правильно, это гадкий вордпрессовский парсер правит. Надо вылечить будет.

  1. No trackbacks yet.